Daily Snippet

Install MonoDevelop 5.1 on fresh Ubuntu 14.04 LTS 64bit

I use davidloo tutorial and I wanna add some point from my experience.

1. sudo apt-get install git automake gnome-sharp2 mono-xsp4

2. git clone https://github.com/mono/monodevelop.git

3. cd monodevelop

4. ./configure –profile=stable

At this point I have error “No package ‘glade-sharp-2.0’ found.” and with ‘monodoc’ package.

The solution is to install that packages from synaptic. 

apt-get install synaptic

Check this on synaptic and click Apply :

Image

Image

 

And run configure again.

4. ./configure –profile=stable

5. sudo make install

And now you have MonoDevelop 5.1 and .net 4.5.

Image

 

Advertisements
Standard

11 thoughts on “Install MonoDevelop 5.1 on fresh Ubuntu 14.04 LTS 64bit

  1. Pingback: Install Mono 3.4.1 on Ubuntu Server 12.04 64bit | Sunday morning

  2. Awesome, your guide really works.
    Just a detail with this line ./configure –profile=stable the “–” is actually a “- -” (double dash, 2 dashes in a row) I think wordpress by some reason shows one dash instead of 2 dashes.

    Thanks for your post, it really helped me.

  3. Darek says:

    During my installation I found problem with missing “referenceassemblies-pcl” package (error during “make”). Installing it using apt-get fixed the problem.

  4. CO M says:

    Not for me:
    cat /etc/lsb-release
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=14.04
    DISTRIB_CODENAME=trusty
    DISTRIB_DESCRIPTION=”Ubuntu 14.04.3 LTS”

    ./configure –profile=stable
    ….
    configure: error: Package requirements (glib-sharp-2.0 >= 2.12.8) were not met:
    No package ‘glib-sharp-2.0’ found

    dpkg -l | grep libglade
    ii libglade2-0:amd64 1:2.6.4-2 amd64 library to load .glade files at runtime
    ii libglade2-dev:amd64 1:2.6.4-2 amd64 development files for libglade
    ii libglade2.0-cil 2.12.10-5 amd64 CLI binding for the Glade libraries 2.6
    marius@brlochin:~/FLEX/LEGO/monodevelop$

    dpkg -l | grep monodoc
    ii monodoc-base 3.2.8+dfsg-4ubuntu1.1 all shared MonoDoc binaries
    ii monodoc-browser 2.11+git20131009.5b1ef35-1build1 all MonoDoc GTK+ based viewer
    ii monodoc-gtk2.0-manual 2.12.26-0xamarin1+compat1 all compiled XML documentation for GTK# 2.10
    ii monodoc-manual 3.2.8+dfsg-4ubuntu1.1 all compiled XML documentation from the Mono project

  5. Pingback: Install Latest MonoDevelop on fresh Ubuntu 14.04 LTS 64bit – Bierman Tech

  6. Pingback: How to install monodevelop 5 on ubuntu 14.04? - ubuntutextbook

  7. Pingback: How to install monodevelop 5 on ubuntu 14.04? - Gomagento2

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s